ICD-10 Certification Preparatory Course

$299.00
+

Important Update: The ICD-10 Certification Preparatory course is updated for 2022. This course was formerly known as the BCHH-C prep course. Upon this review cycle, the SME committee noted the course has expanded benefits in ICD-10 credentialing preparation, hence the name change. Applicability to ICD-10 credentials focused on home health is implied.

We will be mailing out bonus OASIS-D Field Guides to all participants. You do not need this for the course, but may bring it to help you with the OASIS segments of the BCHH-C exam, or other ICD-10 Certification exam. 

Please note: 

  • The OASIS D-1 Field Guide is currently out of stock. We are awaiting a new shipment, and are currently expecting to resume offering this field guide in October. All orders placed now for COQS related products will be shipped a field guide as soon as they are in stock.

Course participants will need a current Home Health ICD-10-CM Diagnosis Coding Manual to participate in the course and exam. You can purchase this through Decision Health or Optum. Make sure you purchase a 2021 code book if you are purchasing a new one.

You have one year from your date of purchase to complete the course and schedule your exam.

Although there are no prerequisites for our ICD-10 Certification Preparatory Course is not a beginner course. Some introductory coding exposure (medical coding & billing program) along with the following is suggested: 

  • Clinical Background (not required).
  • Understanding of medical terms and anatomy and physiology (A&P).
  • Understanding of home health (including eligibility).
  • Good critical thinking and logic skills.

This ICD-10 Homecare specific coding training may be used to prepare for ANY home health coding certification such as the HCS-D or the BCHH-C.


WEB BROWSER REQUIREMENTS

Moodle will operate using the browsers listed below, but typically runs best in the latest versions, so you may want to consider upgrading your browser to the most recent version.

The WellSky Learning Center requires an up-to-date web browser and supports the current versions of Google Chrome, Mozilla Firefox, Microsoft EDGE.

We do not not support Internet Explorer, as Microsoft has ended support for that browser.

  • Internet Connection of 15mbs Download or Better
  • Exceptions in Pop-Up Blocker https://learning.wellsky.com
  • Note: You may find it helpful to have more than one browser installed on your computer. If you run into problems using Moodle, moving to another browser may resolve your issues.

REQUIRED BROWSER SETTINGS

The following browser settings should be selected:

  • Enable Cookies
  • Do not block pop-up windows
  • Note: In some browsers, you can make an exception for Moodle if you don't want to use these settings for all websites.

RECOMMENDED BROWSER ADD-ONS

The following add-ons may need to be installed if your browser is not already configured with them:

  • Adobe PDF Reader and PDF browser plugin will let you view PDFs in a browser window without opening a separate program.
  • Download Adobe Acrobat Reader at http://get.adobe.com/reader/. The download includes the browser plugin. To install this plugin, just follow prompts.

=============================================================================

EXAM Requirements (PROCTORED EXAMS ONLY)

Review the following requirements for your camera, operating system, upload/download speeds, RAM, ports, microphones and browsers. Also included is a list of technology not currently supported by ProctorU.

Minimum Requirements:

  • Internet Connection: Wifi Connection
  • PC Users: Windows 8 (Windows 10 S mode is not supported)Mac Users: MacOS 10.13 (Oldest Still Maintained Version)
  • CPU: more than 2 core CPU less than 85% CPU Usage
  • WebCam: 640x480 resolution
  • Internet Download Speed: 1 Mbps
  • Internet Upload Speed: 1 Mbps
  • RAM: 4 GB less than 95% Ram Usage
  • Connectivity Ports: 1935, 843, 80, 443, 61613, UDP/TCP
  • Screen Resolution: 1366 x 768
  • Chromebook Users: (Only for Automated Proctoring. Is not Supported for Live Proctoring) Chrome device is running the latest version of Chrome OS

Additional Requirements: 

  • A functioning microphone (some web cameras have them built-in)
  • A compatible browser: Google Chrome (preferred) or Mozilla Firefox

Not Supported:

  • Microsoft Internet Explorer, Apple Safari
  • Google Chromebooks (for Live Proctoring only)
  • Tablets (Nexus, iPad, Tab, Note, etc.)
  • Smartphones
  • Linux operating systems
  • Windows 10 in S mode or Surface RT
  • No running inside a virtual machine. You will be asked to reconnect using your host operating system to take your exam
  • Inactive Version of Windows and Test Builds/Test Mode

All courses and tests are accessible for 1 year from the date of purchase.

Customers also bought

At the same price!

Free shipping
$299.00